Community

iOS 9.3.5 에서 현재 SDK를 사용할 수 없나요?

iOS 9.3.5 / iPhone 4s 기기에서 현재 리모트몬스터 SDK를 사용할 수 없나요?

**dyld: Symbol not found: _AVCaptureDeviceTypeBuiltInWideAngleCamera**

**Referenced from: /private/var/containers/Bundle/Application/C1C09381-7028-4B5A-859A-8C728544FF57/Trost_iOS.app/Frameworks/WebRTC.framework/WebRTC (which was built for iOS 10.0)**

**Expected in: /System/Library/Frameworks/AVFoundation.framework/AVFoundation**

**in /private/var/containers/Bundle/Application/C1C09381-7028-4B5A-859A-8C728544FF57/Trost_iOS.app/Frameworks/WebRTC.framework/WebRTC**

이러한 에러가 발생하면서 앱이 실행되지 않고 있습니다.
최소요건이 9.2로 나와있어서 그런줄 알았는데 언제 이렇게 바뀌었는지 모르겠네요… ㅠ
확인 부탁드립니다!

안녕하세요.
iOS 10.0 이전 버전에서 사용하시려면 SDK 2.5.0 이하 버전을 사용하셔야 합니다.

CocoaPod으로 배포되는 GoogleWebRTC 프레임워크의 minimum requirement가 10.0으로 변경되어, SDK 2.5.0 이후 버전부터는 iOS 10.0 이상에서 정상 동작합니다.
되도록 iOS 10.0 이상 버전을 권장드립니다.

감사합니다.