Community

MinSdkVersion 관련 질문

최근 리모트몬스터 SDK가 2.6.x 버전으로 업데이트 되면서
롤리팝 미만의 버전에서는 리모트몬스터가 작동하지 않습니다

가이드 에서는 MinSdkVersion이 18라고 명시되어있던데
예제 를 MinSdkVersion을 18로 하향시키고 테스트 해본 결과
21 버전 미만의 구 기기에서 채널 연결시 okhttp 관련 에러가 발생하고 앱이 죽습니다
Caused by: java.lang.IllegalStateException: Expected Android API level 21+ but was 19

SDK 내부적으로 사용되는 okhttp 버전이 증가되어 최소 SDK 버전이 21인 okhttp 버전으로 변경된 것 같습니다.
롤리팝 미만 기기에서 리모트몬스터가 동작하기 위해서는 어떻게 해야할까요?
추천하시는 방법이 있으시면 알려주시면 감사하겠습니다!

안녕하세요.
9월 말 경 okhttp3를 4.1.0 으로 업그레이드 한뒤로 문제가 발생 한것으로 보입니다.

Remon Android SDK 기능을 추가하면서 생긴 이슈로,
okhttp3를 예전 버전으로 낮춰도 괜찮은지는 별도의 검토가 필요합니다.

검토 후 이상이 없다면, 기존 버전으로 제공하도록 하겠습니다.

롤리팝 미만 버전 지원을 하시려면, 기존에 사용하시던 Remon SDK 를 사용하시기 바랍니다.

감사합니다.

빠른 답변 감사합니다.

Remon Android SDK는 기존에는 2.4.5 버전을 사용했었습니다
서비스 안정성을 위해 문제가 발생하지 않는 최신 SDK를 사용하려 하는데
어떤 버전을 사용하면 좋을까요?

해당 문제에 대한 해결은 언제까지 기다리면 되는지도 말씀해주시면 감사하겠습니다!