Community

Module compiled with Swift 5.1 cannot be imported by the Swift 5.1.2 compiler

안녕하세요

오늘 Xcode 11.2 업데이트를 설치하고 프로젝트를 빌드하려 했는데
Module compiled with Swift 5.1 cannot be imported by the Swift 5.1.2 compiler
라는 에러로 인해 빌드가 불가능한 문제가 있습니다.
혹시 Xcode 다운그레이드가 아닌 다른 workaround가 있을까요…?

현재 설치된 버전은 2.6.11 버전입니다.

안녕하세요.

swift 컴파일러의 경우 애플 정책적인 부분으로 하위 컴파일러를 지원하지 않는 것으로
알고 있습니다.
보통 여러 xcode 버전을 설치해 두고 빌드시 버전을 선택해 사용하고 있습니다.

금일 오후 sdk 2.6.12 버전 업데이트가 예정되어 있습니다.
해당 버전은 xcode 11.2로 빌드된 sdk가 배포될 예정입니다.