Kakao i ConnectLive Q&A 게시판

Next.js 타입스크립트 호환 안되는 에러

안녕하세요

next.js 와 typescript 사용중인 프로젝트에서

npm i @remotemonster/sdk 으로 패키지 설치 하고나서 import 해올 때
모듈을 찾을 수 없다는 에러가 발생합니다.


위 링크인 공식 깃허브에 PR되어있는 자료도 확인하여 적용시켰는데도 import 에러가 해결되지 않습니다
declare 방식으로 했는데도 해결되지 않았습니다

typescript 와 호환해서 사용할 수 있는 방법 문의드립니다.

저희 web sdk 내에 package.json에 일부 정의가 누락되어 발생한 것 같습니다. 패치를 진행할 예정입니다.
감사합니다.

혹시 언제쯤 패치가 진행되는지 알 수 있을까요??

작업하시는 프로젝트 폴더내 디폴트 타입 파일 (예시: main.d.ts) 나 새로 파일을 만들어 (예시: remon.d.ts) 내부에

declare module '@remotemonster/sdk';

선언해주시면 현재상황에서 타입에러가 잡혀 빌드가 안되는 상황은 해결하실수 있습니다.

말씀해주신 내용대로 테스트 해본 뒤 에러가 해결되지 않을 경우에 다시 말씀드리도록 하겠습니다
답변감사합니다

1 Like